injector light again!!!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
injector light again!!!!!!

That flippin' light is back!.....Arranging with Lloyd at clovertech to plug up to the ECU to she what she has to say about it.....But I have noticed one or two other things that you guys may be able to help on.

Have any of you had this injector light problem before

When the light is on I have noticed that my cooling fan comes on and when it gets to 50 to 60 degrees the light and the fan goes off?!!!!

And now my heater doesn't work.. (light or no light)..cold air only!..PS...I have checked and there is enough coolant in there.

Its really doing my nut...I don't wanna fry the engine or cause any other damage....

Any ideas? HELPPPPP! frown
Sponsored Links
Status: -
AO Member
Join Date: Jul 2002
Location: Istanbul
Posts: 20

Member car:

Alfa 145 1.7 16V

Yes I had but it goes off after couple of minutes and it doesn't have a bad effect.

But I don't have any ideas about the cooling fan...
Alfa 145 is offline  
Status: - Update
Posts: n/a
EFI ECU controls the cooling fan, if there is a fault then the fan is automatically switched on. Re no heat, I suspect you have an airlock in the cooling system and would suggest you get it looked at straight away.
Status: - Update
Posts: n/a
Have you come across this before?

Should I just bleed the system. I was told that I might need to change the thermostat. What do you think?

Status: -
AO Member
Roma79's Avatar
Join Date: Jun 2002
Location: UK
Posts: 124
Images: 1
My injector light stayed on today with the key in the MAR position but went out when the engine started. Fuel low warning light came on then - any connection ? Or is that just a stupid question ?

Talking of bleeding the cooling system, I think I need to get about another 2 litres of coolant in (replaced the thermo at the weekend and have got far too much coolant mixture left over). Where's the best place to bleed the air out ?

Thanks ..
Roma79 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

injector , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome