swerving under braking ?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 05-07-02 Thread Starter
Status: -
AO Member
Join Date: Apr 2002
Location: england
Posts: 40
swerving under braking ??

Recently my car has begun to knock at the front end, and it seems to wander and swerve under braking, anybody got any ideas ??

Im led to believe this is quite common on 155`s,
could it be the front lower wishbones ??

gaz155 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2001
Location: Bedfordshire
Posts: 431
I suppose it could be one of many things.
check your shocks for leakage (check rebound for extra bounce)

jack the front wheels up and pull/push the bottom of the wheel if there is movement the ball joints on the wish bones might have some play in them

Are you rear brakes working properly, it might be that all the braking is happening with only your front brakes. (weight transfer is lifting the rear und up)
HWExtreme is offline  
Status: -
AO Silver Member
Join Date: Sep 2001
Location: Dunfermline, Scottyland
Posts: 1,212
sound a fair guess tho...

jason77 is offline  
Status: -
AO Member
craig156's Avatar
Join Date: Oct 2001
Location: south west
Posts: 128

Member car:

156 veloce

Ive got exactly the same problem im ordering some new bearings and im not sure what the other part i need is but i can see play in the lower wish bones when my dad shakes the wheel, but i dont know exactly the part to order, any help guys?
craig156 is offline  
Status: -
AO Member
Roma79's Avatar
Join Date: Jun 2002
Location: UK
Posts: 124
Images: 1

Like 155andproud and your goodself, I've got that same prob on my 146. I had my bearings checked and there was no play but there's alot of wear in my lower wishbone bushes, as mentioned above.

The braking symptoms were much reduced when I put a new set of tyres on for some reason (I had a real hotchpotch collection on my car). I have noticed a slight lean to the driver's side though (hardly noticable from the front but quite pronounced from the back) and I'm hoping that's due to the worn bushes (and maybe the ****e state of my rear shocks). Does yours lean over at all ?

BTW, another AO member has recommended trying Powerflex bushes, says they're really hard wearing.
Roma79 is offline  
Status: - Update
Posts: n/a
Hi Gaz

This has been mentioned on the alfaowner sister site alfa155.com, sounds like the wishbone bushes to me. Poweflex are JUST bringing out replacement bushes for the 155, its taken them a few years wink


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

braking , swerving

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome