Has any one had a proble when fitting strut braces? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 17-09-01 Thread Starter
Status: No more guiletta... Auctioned off
Founder of AO
alfaowner's Avatar
Join Date: Apr 2001
Location: United Kingdom
County: Essex
Posts: 8,044
Images: 83

Member car:

Maserati GTS

Has any one had a proble when fitting strut braces?

Has any had a problem when fitting strut braces to there Alfa?

We bought several makes of strut brace and fitted it to a 155 to try an establish one that fits. But on all braces we had (Which were expensive brand names) there was some kind of modification needed.
Id be interested if you had managed to fit one without any difficulty. Please include your engine size and year of make when replying please.

Thank you
alfaowner is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2001
Location: Sussex, England
Posts: 443

Member car:

Alfa 33 perm 4

I had no probs with an OMP brace for my '91 33 perm 4.
alfanutter is offline  
Status: -
AO Member
Join Date: Jun 2001
Location: Bergerac, France
Posts: 649

Member car:

155 Q4

I've got a Sparco one fitted to my 94 Q4, but had to move the electrical connections that mount on the n/s suspension turret, and it also fouls the power steering resevoir.

Steve Webb is offline  
Status: Lapping Mondello
AO Silver Member
Toad's Avatar
Join Date: Apr 2001
Location: Ireland
County: -
Posts: 1,831

Member car:

75 LE

Ben had problems fitting one to his 155,
Can't remember what though
Toad is offline  
Richard S
Status: - Update
Posts: n/a
I have had a Momo one which fouled the ABS unit a relay box and the air intake temperature sensor but it was easy to fit.

Next I tried an OMP brace which was more difficult to fit (but a lot stronger) and fouled the intake sensor and relays.

The relays aren't a problem but the intake sensor is as I think I damaged a wire which causes he engine to cut out when cornering hard or accelerating and braking. Which happens a lot.

On positive note the car is stiffer.
Status: -
AO Member
Join Date: Jan 2001
Location: Sheffield, South Yorkshir
Posts: 715
I've got the Momo one on my 97 155 2.0.

I've adjusted the pipe to the air filter (K&N) to clear it and put washers under the strut bolts to jack it up a bit. I unhooked the fuse box and pushed it further down, and "adjusted" an ABS brake pipe from the top of the Bosch box to suit.
Henry Yorke is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

braces , fitting , proble , strut

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome