155 Climate Control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
155 Climate Control

I hope someone can tell me whats up with the air con/climate control system on my '97 2.0TS Super.

The thermostat(?) which tells you the internal/external(?) temperature is 'stuck' at -29 and that means that the climate control pretty much blows hot air all the time. Obviously, with summer coming this is going to be a huge problem.

Any help/advice appreciated.
Sponsored Links
Status: -
AO Member
Join Date: Oct 2001
Location: Derbyshire, UK
Posts: 76

Member car:

Saab 900

sound like you may have a problem with your external temperature sensor which is located on the underside of you nearside wing mirror. A friend had the same problem as you when someone very kindly kicked his mirror off.

GB145 is offline  
Status: - Update
Posts: n/a
thanks for the reply.

Could the problem be that the sensor is dirty or needs replacing? What should I do next in an attempt to rectify the problem or does this require paid work?
Status: Lapping Mondello
AO Silver Member
Toad's Avatar
Join Date: Apr 2001
Location: Ireland
County: -
Posts: 1,831

Member car:

75 LE

Inspect the switch,
Is it dirty? could it be damaged ? Is it connected ?if it is connected are the connectors corroded?
Toad is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

155 , climate , control

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome