Alfa 146 1.6TS (1997) Probs!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-04-08 Thread Starter
Status: -
AO Member
Join Date: Aug 2007
Posts: 14
Alfa 146 1.6TS (1997) Probs!!

Hi there

I spoke to a couple of people last week about a fuse box problem, which is all now fixed! Thank you!

I thought I would come back to see if anyone could offer some more guidance please!

2 problems!

The first is the cigarette lighter in the car. It works fine, and when pressed, gets hot! BUT! I cannot charge up my phone nor satnav using any adaptors. I have tried both adaptors and none work - satnav and mobile - although they both work in a friends car! Any ideas???

Secondly - had a recon engine fitted last July from a bunch of cowboys in Essex. Luckily, we got the car checked over as soon as we left the garage, and all was ok! there were a few minor problems, but I managed to claim money back from them via my credit card and got it all fixed. Since having the recon engine fitted, and travelling at around 70mph, the car sounds like it needs another gear (and sounds quite loud)!! When doing 70 mph, the rev counter is just over 35 and sounds quite loud! Also when the car is not moving, the counter is showing at 10mph!! I only had the car 2 weeks before the engine went, and not had an alfa before, so cannot gauge whether this is normal for the car to sound like it needs another gear!

Any ideas??

Any assistance greatly appreciated.

cheztaz is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Alfa 146 1.6TS (1997) Probs!!

No idea about the ciggie lighter, but I would have thought that at 70mph, 3500rpm is fine.

Mt Cloverleaf sist at bang on 3000rpm at 60mph by way of comparison.
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: Alfa 146 1.6TS (1997) Probs!!

the speedo always sits at 10mph, it recalibrates itself there apparently.

145s are pretty noisy, sound insulation is quite poor compared to more modern cars and wind noise especially from the door seals is very poor, sop much so later cars had a revised door seal. Mine gets much noisier at 75 from the doors. Also the gearing is low compared to some cars which is why it does not need a 5 mile run to hit its top speed.


BTW, no idea about the lighter, I would suspect the design is a bit different and the socket is deeper on the Alfa so the contacts do not reach, my Saab was similar. You may have to get behind the console and wire an alternative arrangement in.
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , 16ts , 1997 , alfa , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome