oil pressure low indicator! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-02-08 Thread Starter
Status: -
AO Member
Join Date: Jul 2006
Location: Malaysia
Posts: 30
Images: 2

Member car:

145 1.7L

oil pressure low indicator!

I've got this indicator whenever I'm idling after the engine (boxer) has reached operating temperature (>80deg C). But will go away as soon as revving >900rpm. So thinking of checking in this sequence:

1. oil filter clogged, or the by pass valve problem
2. Sensor problem, try replace with other unit
3. Oil pump, oil pump gears, crankshaft bearings etc

Btw, just did my oil & oil filter change less than 1k km ago. Anybody experience this before?
alfaizal is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2007
Posts: 31

Member car:

146 2.0l TS

Re: oil pressure low indicator!

Doesn't sound too good. If the oil pressure switch has been changed and the problem's still there, then suspect either the oil pump or the main / con-rod bearings. Either way expensive, assuming you can still get the parts.

BTW the oil bypass valve is located on the oil pump so if that is jamming, you will have to replace the entire oil pump anyway. Good luck with changing the oil filter as I don't honest think that would even help at all.

Last edited by ekwan; 06-02-08 at 00:43.
ekwan is offline  
Status: driving a Fiat
AO Member
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 727
Images: 18
Re: oil pressure low indicator!

First thing to check is that there's enough oil in it! Might be leaking or burning...
You've just changed the oil filter, did you have the low pressure before changing it??

If you had crank shell/big end wear that was bad enough to cause you're pressure to drop that low then you would seriously be able to here the engine knocking badly imo

Might be the oil pump or a faulty pressure switch.... but check the other things first. If you're oil pressure really is that low then it cuold badly damage you engine
mo4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

indicator , low , oil , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome