missfire ,popping and banging - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-01-08 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Location: cambridgeshire
Posts: 10
missfire ,popping and banging

please help me someone my 146 1.6 twinspark always used to coff and splutter just for a few seconds in the morning but after a few seconds it would be fine all day .Now it wont run at all it backfires through the carb an exhaust but occasionally it will stricke up fine for a few seconds ,weird ,ive cleaned the relays and connections in front of battery ,i can hear the fuel pump working when i switch on ignition.Also i read lots about MAF ,does my model have one if so where is it situated ? . Im thinking crank sensor .my friend has just purchased the new fandango snap-on diagnostic kit but is waiting for its delivery . please help as at the minute im one sad alfa owner...................
marc p is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: missfire ,popping and banging

They don't have carbs; all TS engines are injected not carbureted.

MAF sits just after the air filter box (DO NOT buy one from Ebay) but I doubt it is to blame from the symptoms you have described - they sound more "electrical" which is unusaul for an Alfa. Not.

Last edited by Rosso145; 27-01-08 at 17:14.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

banging , missfire , popping

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome